[已解决]管理服务器和辅助存储合一,CS界面不识别二级存储大小及系统VM异常

QQ图片20150629143803.png

请教个问题,管理和二级存储在一台机器上,但是CS不识别二级存储大小啊,

QQ图片20150629143854.png

相对应的系统VM状态也不正常,我注册的ISO镜像也一直下不来
想了想应该还是二级存储配置的问题,但是根源找不出来,请教下学长帮分析下?
已邀请:

imbean

赞同来自: ak_qq

系统虚拟机代理状态异常,请使用以下方法检查:
1. SSVM自检,查看报错异常。
root@s-2-VM:~# sh /usr/local/cloud/systemvm/ssvm-check.sh 
(二级存储显示为0kb,一般为二级存储挂载异常,查看存储网络的路由)
2. ISO/Template 上传,下载等均通过SSVM,SSVM状态异常,则相关的操作也会失败。
 
更多SSVM排错请参考以下链接:
https://cwiki.apache.org/confl ... /SSVM,+templates,+Secondary+storage+troubleshooting
 

ak_qq

赞同来自: chenliang

加不加vlan id,要根据情况判断。
chenliang和春雨说的都对。

在cloudstack中,管理网络,不会让你加vlan id(vmware环境除外,在流量标签中会有定义vlan id的选项), 而存储、公共,会询问你是否加vlan id,而此时究竟是加还是不加,遵循以下:
1. 加不加vlan id,取决与你的物理网卡对应交换机端口的配置。
如果,你的存储,公共网络,所对应的网络标签(其实最终就是定位到服务器网卡),与交换机相连的这个端口,是access还是trunk?
如果是access,那就说明不需要再加vlan id,如果是trunk模式,那你就需要添加vlan id。
为何?如果是access模式了,那表示什么?表示你的网卡已经属于某个vlan了。对吧。从该网卡出去的流量,再经过交换机端口时,会自动帮你封装,加上vlan id。  而如果你又加上一个vlan id,流量从网卡出去时,给你封装了一个vlan id,经过交换机端口,又在外层封装了一个vlan id,你们觉得会有问题不?答案是肯定的。
如果是trunk模式,表示从网卡出来的流量必须带vlan id,如果不带,交换机端口不知道该如何帮你转发。但也有一个特殊情况,就是native vlan。就是交换机端口的本证vlan,注意,每个端口只能有一个本证vlan,默认是vlan 1. 用途就在与,如果一个没有带vlan id的流量经过trunk口,该trunk口会给你自动打上native vlan的id。如果没有配置native,而你的流量又没带vlan id,那抱歉,无法通信。

cs中让你填写的vlan id,是在服务器上面,流量从网卡出来时,打不打vlan id的依据。
而交换机中端口配置的vlan id,是在流量从服务器出来,经过交换机时,作为一个判断依据。

原则就是,如果交换机对应端口是access,则流量从网卡出来时,不能带vlan id,也就是在cs中不需要填vlan。
               如果交换机对应端口是trunk,则流量从网卡出来时,必须带vlan id,也就是在cs中需要填vlan。
               如果交换机端口是trunk,且配置了native vlan,就需要判断,native vlan的id,和你对应的流量是否是同一个id,如果是同一个,则不需要填写,如果不是,则需要填写。

以上。

ak_qq

赞同来自:

麻烦下次发帖时,尽可能详细的描述你的问题,可以参照发帖模版发帖。

系统虚拟机vm状态为running,表示虚拟机已经创建并启动成功。
代理状态为空,表示系统虚拟机跟管理端通信异常(不通)。

所以,检查你的网络配置。

SkyXiaoT - 农民工

赞同来自:

目前的设备排查问题基本都排查了,无异常情况,发几个图片和日志,麻烦学长分析下
8250端口也正常开启。在kvm主机上挂载二级存储也能正常挂载

 

春雨

赞同来自:

流量标签与网络实际不一致造成的,改过来就好了

chenliang - 技术就是创新

赞同来自:

我的问题跟你一样,请问流量标签与网络实际不一致,是在哪里啊修改啊?
 

春雨

赞同来自:

在web界面中改,另外若为单独的计算节点,最好设置完后重启一下,一般可解决。

chenliang - 技术就是创新

赞同来自:

是在创建高级区域的时候,在设置网络那个步骤,修改流量标签与网络对应的吗?

春雨

赞同来自:

是的

chenliang - 技术就是创新

赞同来自:

嗯,可以了,我的添加存储网络的时候,把vlanid加上去了,这个在交换机上设置的是access,不需要加vlanid的。

春雨

赞同来自:

有时,vlan加上反而会不通,可能是环境不同!

天使

赞同来自:

网络问题。交换机配置吧。

春雨

赞同来自:

正如aq所说,一般就是交换机配置问题,且首先找最近的交换机的配置。

春雨

赞同来自:

正如aq所说,一般就是交换机配置问题,且首先找最近的交换机的配置。

春雨

赞同来自:

正如aq所说,一般就是交换机配置问题,且首先找最近的交换机的配置。

春雨

赞同来自:

正如aq所说,一般就是交换机配置问题,且首先找最近的交换机的配置。

春雨

赞同来自:

正如aq所说,一般就是交换机配置问题,且首先找最近的交换机的配置。

春雨

赞同来自:

正如aq所说,一般就是交换机配置问题,且首先找最近的交换机的配置。

春雨

赞同来自:

正如aq所说,一般就是交换机配置问题,且首先找最近的交换机的配置。

春雨

赞同来自:

正如aq所说,一般就是交换机配置问题,且首先找最近的交换机的配置。

春雨

赞同来自:

正如aq所说,一般就是交换机配置问题,且首先找最近的交换机的配置。

春雨

赞同来自:

正如aq所说,一般就是交换机配置问题,且首先找最近的交换机的配置。

春雨

赞同来自:

正如aq所说,一般就是交换机配置问题,且首先找最近的交换机的配置。

要回复问题请先登录注册